Получение Subclipse в Aptana для работы с новейшим выпуском Subversion

голоса
34

Версия Subclipse (1.2.4) доступна в настоящее время с помощью автоматического Aptana в диспетчере плагин не работает с новейшей версией Subversion.

Я вижу на сайте Subclipse , однако , что у них есть 1.4.2 из Затмения. Поэтому я добавил новый сайт удаленного обновления для моего менеджера обновлений. Когда я попытался установить его, он сказал мне , что мне нужно Mylyn 3.0.0 . Таким образом , после долгих поисков я нашел Mylyn 3.0.0 и добавил еще один новый сайт удаленного обновления для моего менеджера обновлений. Затем , когда я попытался установить , что он сказал мне , что мне нужно org.eclipse.ui 3.3.0 или эквивалент.

Глядя на детали конфигурации для Aptana, похоже, что он построен против затмения 3.2.2.

Кто-нибудь знает, есть ли способ обновить версию Eclipse, Aptana, который построен в отношении к 3.3.0? Или, если есть какой-то другой способ получить Subclipse работать с очень новейшей версией Subversion?

Я знаю, что это не обязательно «программирование» вопрос, но я надеюсь, что это нормально, так как это весьма важное значение для опыта программирования.

Задан 01/08/2008 в 14:56
источник пользователем
На других языках...                            


4 ответов

голоса
16

Subclipse не требует Mylyn, но обновление сайта включает в себя модуль, который интегрирует Mylyn и Subclipse. Он предназначен для людей, которые используют Mylyn. В вашем случае, вы хотели бы просто отменить выбор Mylyn в диалоге обновления.

Subclipse также требует Subversion 1.5 и соответствующую версию нативных библиотек JavaHL. Я написал начало из FAQ , чтобы помочь людям понять JavaHL и как его получить. См: http://desktop-eclipse.open.collab.net/wiki/JavaHL

Ответил 15/09/2008 в 14:26
источник пользователем

голоса
6

У меня были проблемы с JavaHL в Eclipse, Ганимед, когда он работал отлично в Eclipse Europa. Я не знаю, как Aptana разные, но попробуйте либо модернизации JavaHL или переход к реализации SVNKit чисто ява в Subclipse конфигурации.

Ответил 01/08/2008 в 15:41
источник пользователем

голоса
4

если вы не собираетесь использовать Mylyn просто снять эту зависимость. Я не очень знаком с Aptana, но в затмении вы можете расширить Whats устанавливается, и снимите все, что вам не нужно.

Ответил 29/08/2008 в 00:47
источник пользователем

голоса
3

Я использовал URL обновления и я установил адаптер JavaHL, сам Subclipse проект и в SVNKit адаптер BETA.

После этого он работал отлично для меня, это для Linux Platform надеемся, что он работает для вас.

Ответил 26/08/2008 в 14:41
источник пользователем

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more