Таблица оказывает ошибку в реакции компонентов 6.0.1

голоса
0

Я работаю над обновлением нашего @ gooddata / пакет реагирующей-компонента, начиная с версии 5.3.1 до версии 6.0.1. У меня было несколько таблиц прозрений, работающих хорошо, но теперь некоторые из них не в состоянии сделать с этой ошибкой:

Warning: React.createElement: type is invalid -- expected a string (for built-in components) or a class/function (for composite components) but got: undefined. You likely forgot to export your component from the file it's defined in. Check the render method of 'BubbleHoverTrigger'.

Я передаю то же самое , propsкак я был с 5.3.1, так почему мои идеи в настоящее время не в состоянии загрузить?

Задан 07/11/2018 в 19:59
источник пользователем
На других языках...                            


3 ответов

голоса
1

Стюарт, вы определенно можете предоставить его через открытие вопроса о хранилище GitHub , если здесь нет места в комментариях: https://github.com/gooddata/gooddata-react-components

Ответил 09/11/2018 в 12:09
источник пользователем

голоса
1

Я столкнулся с той же ошибкой и фиксировал его путем обновления до React 16 из 15 React я использовал раньше. В @gooddata/react-componentsиспользует новый Реагировать начиная с версии 6.0.0.

Ответил 08/11/2018 в 12:34
источник пользователем

голоса
1

Спасибо Стюарт, для отчета.

Мы будем исследовать. Не могли бы вы сказать нам , какой компонент не удается , и какой тип реквизита вы посылаете? Является ли это спасло <Visualization />или. Похоже , пропавшего испытания на нашей стороне. Наши автоматизированные тесты , как правило , поймать их.

Ответил 08/11/2018 в 12:30
источник пользователем

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more