Список предыдущих версий, доступных для пакета и установить один из них АПП-получить

голоса
0

10.5-2Версия , postgresqlкоторая исходит из
deb http://apt.postgresql.org/pub/repos/apt/ stretch-pgdg main
хранилища есть проблема, и я хотел бы вернуться к 10.4версии , которую я знаю , чтобы работать так , как я хочу.

apt-cache madison postgresql-10возвращает мне эти сведения атм:
postgresql-10 | 10.5-2.pgdg90+1 | http://apt.postgresql.org/pub/repos/apt stretch-pgdg/main amd64 Packages postgresql-10 | 10.5-2.pgdg90+1 | http://apt.postgresql.org/pub/repos/apt stretch-pgdg/main Sources

Как я могу найти предыдущую версию пакетов (ов) для существующего 10.4?
Когда я пытаюсь использовать номер версии я нашел где - то (на сайте шоколадным: Я не имел ни малейшего понятия о том , как искать и был немного потерян), это не удалось: sudo apt-get install postgresql-10=10.4.0.20180721 E: Version '10.4.0.20180721' for 'postgresql-10' was not found

Отправляясь в postgresqlхранилище, http://apt.postgresql.org/pub/repos/apt/dists/stretch-pgdg/ , я не нашел ни малейшего понятия о том , как получить любую предыдущую версию.

В более общем плане , что путь, через командную строку и профпригодности команд, чтобы перечислить то , что предыдущие версии могут быть установлены для упаковки?
Есть, например, стандарт , который устанавливается другое место для предыдущих версий, как архив хранилища Я всегда должен найти в виде HTTP: //../ архив /../, или что - то другое?

Спасибо !

Задан 20/10/2018 в 05:34
источник пользователем
На других языках...                            


1 ответов

голоса
1

apt-cache showpkg <package-name> будут перечислены все доступные версии

Любой из них

  • apt install <package-name>=<package-version-number>
  • apt -t=<target release> install <package-name>

apt-mark hold <package-name> позволит предотвратить автоматическое обновление

PostgreSQL теперь на версии 11 доступна на главном сайте.

На GitHub, рядом с «сделать запрос тянуть» нажмите на мастера, выбор изменений в '10 стабильный», а затем сделать запрос тянуть. Вам нужно исправить ошибку, если 10 устойчивее 10,5. Если это не так легко, вы можете сравнить код с 9,5 стабильных - только 1066 файлов, которые были изменены и пройти через изменение их. Воняет, что они фактически не держать тег для других версий.

Источники: https://askubuntu.com/questions/138284/how-to-downgrade-a-package-via-apt-get#138327

Edit: Не забудьте обновить, прежде чем проверять наличие доступных пакетов.

Ответил 20/10/2018 в 06:01
источник пользователем

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more