SQL Server 2005 и 2008 на той же машине разработчика?

голоса
20

Кто-нибудь пробовал установки SQL Server 2008 Developer на машине, которая уже установлена ​​2005 Developer?

Я уверен, если я должен делать это, и мне нужно, чтобы держать 2005 на этой машине в обозримом будущем для того, чтобы проверить наше приложение легко. Так как я иногда нужно принимать файлы резервных копий баз данных и сделать доступную для других людей в компании я не могу просто заменить 2005 с 2008, как я подозреваю (но не знаю), что базы данных не 100% обратная совместимость.

Какие проблемы возникли бы? Мне нужно установить новую версию с именем экземпляра, будет работать, что ли? Могу ли я использовать другой номер порта, чтобы отличить их?

Я нашел эту запись на веб -сайте TechNet: http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3496209&SiteID=17

Он не говорит больше , чем просто да , вы можете сделать это , и я вроде подозревал , что это выполнимо в любом случае, но мне нужно знать , если есть что - то мне нужно знать , прежде чем начать установку.

Кто угодно?

Задан 07/08/2008 в 09:35
источник пользователем
На других языках...                            


7 ответов

голоса
23

Да, это возможно. Вы должны создать именованный экземпляр не используется другой версии SQL Server в соответствии с предыдущим ответом и версии 3.5 .Net установлена. Прекрасно работает!!

Вот список предпосылок:

  • .NET Framework 3.5 SP1
  • Установщик Windows 4.5
  • Windows PowerShell 1.0
Ответил 07/08/2008 в 10:30
источник пользователем

голоса
3

Если у вас есть Visual Studio 2008 установлена, вы получите ошибку проверки, и вы не можете установить SQL Server 2008 до установки Visual Studio 2008 SP1. Если у вас нет Visual Studio 2008 установлено, что не должно быть проблемой. Так что если у вас есть Visual Studio 2008 ждать до 11-го августа, так что на следующий день, что Visual Studio 2008 SP1 будет поставляться

Ответил 08/08/2008 в 14:23
источник пользователем

голоса
2

Я считаю, что это вполне возможно. Я в настоящее время работаю как SQL Server 2000 и SQL Server 2005 на моем сервере разработки в то время как я передаю приложения через.

Единственное, что вы должны сделать, это создать новый экземпляр, который не уже используется SQL Server 2005.

Как и все новое, то, вероятно, какие-то ошибки, однако, как правило, должны «просто работать».

Ответил 07/08/2008 в 09:57
источник пользователем

голоса
1

Вы можете запустить только SQL 2008, как один экземпляр, а затем присоединить / создавать базы данных с уровнем совместимости 2005? Проблема в том, что его теории. Я не 100% уверен, что если вы создаете базу данных в 2008 году, с уровнем СОВМЕСТИМОСТИ 2005 года, а затем снимите его, что экземпляр SQL 2005 способен прикрепляться его.

Я думаю, что его достаточно хороший шанс попробовать хотя. Но я согласен с предыдущими ответами, несколько вариантов экземпляра будет работать нормально.

Ответил 13/07/2009 в 20:07
источник пользователем

голоса
1

мой опыт после того, как SQL Server 2005, и 2008 на той же машине SSIS 2005 не работает должным образом ... специально с задачей сценария, поток данных и контейнер последовательности

Ответил 13/05/2009 в 09:42
источник пользователем

голоса
0

У меня попробовать это Negativ результат. Установка 2k8 порывает с загадочным сообщением об ошибке. Установка протоколов выглядит хорошо, но это не будет работать. После этого установка 2k5 тоже глючит. Установка 2k8 была наполовину готова, так подмигнули уже в ControlPane / программное обеспечение, но удаление не представляется возможным.

Так что мой результат - don't сделать это на продуктивный сервер / рабочей станции. Если вам нужны обе версии, используйте вместо этого виртуальную машину.

Ответил 03/08/2009 в 11:59
источник пользователем

голоса
0

К сожалению, это, кажется, 2008 Client Tools SQL Server требует Visual Studio 2008 SP1, и я не желая установить бета-это на моей основной машине развития.

Я буду ждать до тех пор, пока SP1 RTM, прежде чем я перейду.

Edit : Да, у меня есть Visual Studio 2008 на этой машине, но я хотел бы избежать бета - установок отладчика приложений. Они , как правило , вырыть себе слишком глубоко в мой вкус.

Ответил 08/08/2008 в 13:57
источник пользователем

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more