mp4, WebM видео файлы OGG не играет при вызове из веб-сервера

голоса
0
<!DOCTYPE html PUBLIC -//W3C//DTD XHTML 1.0 Transitional//EN http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd>
<html xmlns=http://www.w3.org/1999/xhtml>
<head>
<meta http-equiv=Content-Type content=text/html; charset=utf-8 />
<title>Untitled Document</title>
<style type=text/css>
<!--
.tb_bg {
background-image: url(../images/audi/audi_land.jpg);
background-repeat: no-repeat;
background-position: center center;
   }
   .vid_pos{
position:static;
   }
   #apDiv1 {
position:absolute;
width:255px;
height:163px;
z-index:1;
left: 69px;
top: 478px;
   }
 -->
 </style>
 </head>

  <body>
 <div id=apDiv1 class=vid_pos>
 <video width=350 height=220 preload=meta controls=controls      poster=../images/audi/audi_poster.png>

 <source src=../videos/audi/audi.mp4 type='video/mp4; codecs=avc1.42E01E, mp4a.40.2' />

 <source src=../videos/audi/audi.webm type='video/webm; codecs=vp8, vorbis' />

 <source src=../videos/audi/audi.ogg type='video/ogg; codecs=theora, vorbis' />

  <object type=application/x-shockwave-flash style=width: 300px; height: 170px; data=http://releases.flowplayer.org/swf/flowplayer-3.2.1.swf?flv=/videos/audi/dell_audi.mp4&amp;amp;autoplay=false>

 <param name=movie value=http://releases.flowplayer.org/swf/flowplayer-3.2.1.swf />

  <param name=wmode value=transparent />

  </object>
  </video>

   </div>
    <table width=800 height=1005 border=0 cellpadding=1 cellspacing=1              class=tb_bg>
     <tr>
      <td height=1003>&nbsp;</td>
      </tr>
      </table>

      </body>
      </html>

Там нет ошибки в кодировании. Когда я открываю файл выше во всех 3-х браузеров Chrome, IE и Firefox, видео играет. но после того, как я загружать видео файлы и HTML-файлы на сервер и вызовите страницу, видео не воспроизводится на Firefox и IE. Он работает на Google Chrome ..

Там нет PHP или Apache в этом замешан ...

Пространство сервер от www.godaddy.com ..

Когда я открываю файл в Firefox: Я получаю следующее сообщение, где я разместил видео файл: «Нет видео с поддерживаемым форматом и MIME типа найдено»

и IE я вижу только -audi_poster.png изображения

Что мне теперь делать? Видео играет, когда я открываю из моих локальных дисков во всех 3 браузеров .. Я не почему он не работает, когда я загрузить на сервер и назовите его .. Любой дополнительный материал, необходимый ?? Pls помочь ..

Задан 19/06/2012 в 05:39
источник пользователем
На других языках...                            


1 ответов

голоса
4

Ваш веб - сервер должен отвечать на браузер с правильным заголовком Content-Type. Для WebM, "видео / WebM. Подробнее здесь .

Ответил 21/06/2012 в 19:39
источник пользователем

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more